using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+(?:\.\d+)?).*?(\d+(?:\.\d+)?)";
string input = @"""Размер экрана"": 4.5 - 5""
""Размер экрана"": 4.5 - 5.5""
""Размер экрана"": 100- 500.5""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}