$re = '/(\d+(?:\.\d+)?).*?(\d+(?:\.\d+)?)/';
$str = '"Размер экрана": 4.5 - 5"
"Размер экрана": 4.5 - 5.5"
"Размер экрана": 100- 500.5"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);