using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[\d+-/*()]+$";
string input = @"(5+5)-(5)+(-2)
(5+5)/2-1
(5+5)/(3-1)
(5+5)/(3-1
5+
(5+5)/()
(a+b)/5";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}