package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\d+-/*()]+$`)
var str = `(5+5)-(5)+(-2)
(5+5)/2-1
(5+5)/(3-1)
(5+5)/(3-1
5+
(5+5)/()
(a+b)/5`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}