import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\d+-/*()]+$";
final String string = "(5+5)-(5)+(-2)\n"
+ "(5+5)/2-1\n"
+ "(5+5)/(3-1)\n"
+ "(5+5)/(3-1\n"
+ "5+\n"
+ "(5+5)/()\n"
+ "(a+b)/5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}