re = /^[\d+-\/*()]+$/m
str = '(5+5)-(5)+(-2)
(5+5)/2-1
(5+5)/(3-1)
(5+5)/(3-1
5+
(5+5)/()
(a+b)/5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end