using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\$cdt\[([a-zA-Z_][a-zA-Z0-9_]{3,100}),([a-zA-Z0-9_+\-*/%&|^!=<>\[\]$ ]{1,500}),([a-zA-Z0-9_+\-*/%&|^!=<>\[\]$ ]{1,500}),?([a-zA-Z0-9_\- ]{1,100}=[a-zA-Z0-9_+\-*/%&|^!=<>\[\]$ ]{1,500}(?:;[a-zA-Z0-9_\- ]{1,100}=[a-zA-Z0-9_+\-*/%&|^!=<>\[\]$ ]{1,500})*)?]$";
string input = @"$cdt[cdt1,$[col1]-4==1,$[col2]+$[col3],var1=1;var2=2+1;var3=6==6]
$cdt[cdt1,$[col1]-4==1,$[col2]+$[col3]]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}