using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(long|anyword)\b\K[- ](?=(?:(?1))\b)";
string substitution = @"-";
string input = @"Sample text:
test text long long test text
test text long long long long long long test text
test text long long test test long long long test text
How it should be:
test text long-long test text
test text long-long-long-long-long-long test text
test text long-long test test long-long-long test text
How does it work now:
test text long-long test text
test text long-long long-long long-long test text
test text long-long test test long-long long test text";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}