const regex = /\b(long|anyword)\b\K[- ](?=(?:(?1))\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(long|anyword)\\b\\K[- ](?=(?:(?1))\\b)', 'gm')
const str = `Sample text:
test text long long test text
test text long long long long long long test text
test text long long test test long long long test text
How it should be:
test text long-long test text
test text long-long-long-long-long-long test text
test text long-long test test long-long-long test text
How does it work now:
test text long-long test text
test text long-long long-long long-long test text
test text long-long test test long-long long test text`;
const subst = `-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);