import re
regex = re.compile(r"\b(long|anyword)\b\K[- ](?=(?:(?1))\b)", flags=re.MULTILINE)
test_str = ("Sample text:\n"
"test text long long test text\n"
"test text long long long long long long test text\n"
"test text long long test test long long long test text\n\n"
"How it should be:\n"
"test text long-long test text\n"
"test text long-long-long-long-long-long test text\n"
"test text long-long test test long-long-long test text\n\n"
"How does it work now:\n"
"test text long-long test text\n"
"test text long-long long-long long-long test text\n"
"test text long-long test test long-long long test text")
subst = "-"
result = regex.sub(subst, test_str)
if result:
print(result)