#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\d)(?<!\d )(?:(?:\d *){13}|(?:\d *){10})(?<! )(?! ?\d)"
Local $sString = "2442141411" & @CRLF & _
"One 2 442141411 two 24 42141411 three" & @CRLF & _
"2 44214141 1" & @CRLF & _
" 2 6 9 32 2 3 8 376 67" & @CRLF & _
"2 6 9 32 2 3 87 77 67 8" & @CRLF & _
"2 6 9 32 2 3 8 37667" & @CRLF & _
"2442141411 123" & @CRLF & _
"2442141411 1" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")