$re = '/(?<!\d)(?<!\d )(?:(?:\d *){13}|(?:\d *){10})(?<! )(?! ?\d)/m';
$str = '2442141411
One 2 442141411 two 24 42141411 three
2 44214141 1
2 6 9 32 2 3 8 376 67
2 6 9 32 2 3 87 77 67 8
2 6 9 32 2 3 8 37667
2442141411 123
2442141411 1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);