import Foundation
let pattern = #"(?<!\d)(?<!\d )(?:(?:\d *){13}|(?:\d *){10})(?<! )(?! ?\d)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2442141411
One 2 442141411 two 24 42141411 three
2 44214141 1
2 6 9 32 2 3 8 376 67
2 6 9 32 2 3 87 77 67 8
2 6 9 32 2 3 8 37667
2442141411 123
2442141411 1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)