import re
regex = re.compile(r"(?<!\d)(?<!\d )(?:(?:\d *){13}|(?:\d *){10})(?<! )(?! ?\d)", flags=re.MULTILINE)
test_str = ("2442141411\n"
"One 2 442141411 two 24 42141411 three\n"
"2 44214141 1\n"
" 2 6 9 32 2 3 8 376 67\n"
"2 6 9 32 2 3 87 77 67 8\n"
"2 6 9 32 2 3 8 37667\n"
"2442141411 123\n"
"2442141411 1\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")