#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?m)}$.*?}$"
Local $sString = "está no fim da linha, deve pegar -> }" & @CRLF & _
"qualquer texto, \" blablá etc" & @CRLF & _
"linha } <- não está no final da linha, deve pular" & @CRLF & _
"tem que pegar esse, pois está no fim da linha }" & @CRLF & _
"asdasdasasdsaeeeee " & @CRLF & _
"{" & @CRLF & _
"aaaaaa" & @CRLF & _
"adsasdassdasdfff } <- não está no final da linha, não deve pegar" & @CRLF & _
"qualquer texto, \" blablá etc" & @CRLF & _
"asdasdasasdsa}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")