// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)(?m)}$.*?}$").unwrap();
let string = "está no fim da linha, deve pegar -> }
qualquer texto, \\\" blablá etc
linha } <- não está no final da linha, deve pular
tem que pegar esse, pois está no fim da linha }
asdasdasasdsaeeeee
{
aaaaaa
adsasdassdasdfff } <- não está no final da linha, não deve pegar
qualquer texto, \\\" blablá etc
asdasdasasdsa}
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}