$re = '/(?s)(?m)}$.*?}$/';
$str = 'está no fim da linha, deve pegar -> }
qualquer texto, \\" blablá etc
linha } <- não está no final da linha, deve pular
tem que pegar esse, pois está no fim da linha }
asdasdasasdsaeeeee
{
aaaaaa
adsasdassdasdfff } <- não está no final da linha, não deve pegar
qualquer texto, \\" blablá etc
asdasdasasdsa}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);