import re
regex = re.compile(r"(?s)(?m)}$.*?}$")
test_str = ("está no fim da linha, deve pegar -> }\n"
"qualquer texto, \\\" blablá etc\n"
"linha } <- não está no final da linha, deve pular\n"
"tem que pegar esse, pois está no fim da linha }\n"
"asdasdasasdsaeeeee \n"
"{\n"
"aaaaaa\n"
"adsasdassdasdfff } <- não está no final da linha, não deve pegar\n"
"qualquer texto, \\\" blablá etc\n"
"asdasdasasdsa}\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")