#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Code:\s(.*)$"
Local $sString = "Hi," & @CRLF & _
"You got a new answer from user Alex. " & @CRLF & _
" " & @CRLF & _
"Code: alex123fj" & @CRLF & _
"Number1: 0611111111" & @CRLF & _
"Number2: 1020" & @CRLF & _
"Number3: 3032"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")