package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Code:\s(.*)$`)
var str = `Hi,
You got a new answer from user Alex.
Code: alex123fj
Number1: 0611111111
Number2: 1020
Number3: 3032`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}