import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Code:\\s(.*)$";
final String string = "Hi,\n"
+ "You got a new answer from user Alex. \n"
+ " \n"
+ "Code: alex123fj\n"
+ "Number1: 0611111111\n"
+ "Number2: 1020\n"
+ "Number3: 3032";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}