const regex = /^(?:[0-9]{9,15}|(?=[a-zA-Z]*[0-9])(?=[0-9]*[a-zA-Z])[A-Za-z0-9]{6,15})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[0-9]{9,15}|(?=[a-zA-Z]*[0-9])(?=[0-9]*[a-zA-Z])[A-Za-z0-9]{6,15})$', 'gm')
const str = `123456789
12345678Y
Y234Y2
Should not be valid:
12345678
123X4
ABCDEFGHYJ
- Contains between 9 and 15 numbers (Only numbers)
- Contains between 6 and 15 numbers+letters (it must contain both, numbers and letters. Only letters is not a valid option).
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}