use strict;
my $str = '123456789
12345678Y
Y234Y2
Should not be valid:
12345678
123X4
ABCDEFGHYJ
- Contains between 9 and 15 numbers (Only numbers)
- Contains between 6 and 15 numbers+letters (it must contain both, numbers and letters. Only letters is not a valid option).
';
my $regex = qr/^(?:[0-9]{9,15}|(?=[a-zA-Z]*[0-9])(?=[0-9]*[a-zA-Z])[A-Za-z0-9]{6,15})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}