import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https:\\/\\/www.google.com\\/(?:\\S*)!1s(\\S+)!3";
final String string = "https://www.google.com/maps/api/js/ReviewsService.LoadWriteWidget?key=AIzaSyBcv0QfUNUfBwo8pIGJ3teNCkaluSGUWus&authuser=0&pb=!2m1!1sChIJmQ0yuZ-gToYRJySW6BCQc6M!3shttps%3A%2F%2Fwww.google.com!5sen&cb=99146092";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}