use strict;
my $str = 'https://www.google.com/maps/api/js/ReviewsService.LoadWriteWidget?key=AIzaSyBcv0QfUNUfBwo8pIGJ3teNCkaluSGUWus&authuser=0&pb=!2m1!1sChIJmQ0yuZ-gToYRJySW6BCQc6M!3shttps%3A%2F%2Fwww.google.com!5sen&cb=99146092';
my $regex = qr/^https:\/\/www.google.com\/(?:\S*)!1s(\S+)!3/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}