// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^https:\/\/www.google.com\/(?:\S*)!1s(\S+)!3").unwrap();
let string = "https://www.google.com/maps/api/js/ReviewsService.LoadWriteWidget?key=AIzaSyBcv0QfUNUfBwo8pIGJ3teNCkaluSGUWus&authuser=0&pb=!2m1!1sChIJmQ0yuZ-gToYRJySW6BCQc6M!3shttps%3A%2F%2Fwww.google.com!5sen&cb=99146092";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}