import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![^\\/])t\\.me\\/(?!.*?joinchat)(?!.*bot$)[a-zA-Z0-9_]{5,32}$";
final String string = "https://t.me/group1\n"
+ "https://t.me/group2\n"
+ "https://t.me/botgroup1\n"
+ "https://t.me/groupbot\n"
+ "https://t.me/group_bot\n"
+ "https://t.me/joinchat/xR7tqA43Dg\n"
+ "https://www.google.com/en/blabla";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}