import re
regex = re.compile(r"(?<![^\/])t\.me\/(?!.*?joinchat)(?!.*bot$)[a-zA-Z0-9_]{5,32}$", flags=re.MULTILINE)
test_str = ("https://t.me/group1\n"
"https://t.me/group2\n"
"https://t.me/botgroup1\n"
"https://t.me/groupbot\n"
"https://t.me/group_bot\n"
"https://t.me/joinchat/xR7tqA43Dg\n"
"https://www.google.com/en/blabla")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")