re = /(?<![^\/])t\.me\/(?!.*?joinchat)(?!.*bot$)[a-zA-Z0-9_]{5,32}$/m
str = 'https://t.me/group1
https://t.me/group2
https://t.me/botgroup1
https://t.me/groupbot
https://t.me/group_bot
https://t.me/joinchat/xR7tqA43Dg
https://www.google.com/en/blabla'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end