const regex = /(?<![^\/])t\.me\/(?!.*?joinchat)(?!.*bot$)[a-zA-Z0-9_]{5,32}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<![^\\\/])t\\.me\\\/(?!.*?joinchat)(?!.*bot$)[a-zA-Z0-9_]{5,32}$', 'gm')
const str = `https://t.me/group1
https://t.me/group2
https://t.me/botgroup1
https://t.me/groupbot
https://t.me/group_bot
https://t.me/joinchat/xR7tqA43Dg
https://www.google.com/en/blabla`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}