#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Z]+[a-z]+[\s]+[a-z]+[\.!\?]$"
Local $sString = "This is a sentence." & @CRLF & _
"This is not a sentence" & @CRLF & _
"!This is not a sentence either" & @CRLF & _
"this is also not a sentence." & @CRLF & _
"Is this a sentence?" & @CRLF & _
"Is THIS A SENTENCE too?" & @CRLF & _
"How isthisasentence?" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")