re = /^[A-Z]+[a-z]+[\s]+[a-z]+[\.!\?]$/m
str = 'This is a sentence.
This is not a sentence
!This is not a sentence either
this is also not a sentence.
Is this a sentence?
Is THIS A SENTENCE too?
How isthisasentence?
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end