using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Z]+[a-z]+[\s]+[a-z]+[\.!\?]$";
string input = @"This is a sentence.
This is not a sentence
!This is not a sentence either
this is also not a sentence.
Is this a sentence?
Is THIS A SENTENCE too?
How isthisasentence?
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}