package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z]+[a-z]+[\s]+[a-z]+[\.!\?]$`)
var str = `This is a sentence.
This is not a sentence
!This is not a sentence either
this is also not a sentence.
Is this a sentence?
Is THIS A SENTENCE too?
How isthisasentence?
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}