using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((((0[1-9]|[1-2][0-9]|3[0-1])\.(0[1]))|((0[1-9]|[1-2][0-8])\.(0[2]))|((0[1-9]|[1-2][0-9]|3[0-1])\.(0[3]))|((0[1-9]|[1-2][0-9]|3[0])\.(0[4]))|((0[1-9]|[1-2][0-9]|3[0-1])\.(0[5]))|((0[1-9]|[1-2][0-9]|3[0])\.(0[6]))|((0[1-9]|[1-2][0-9]|3[0-1])\.(0[7]))|((0[1-9]|[1-2][0-9]|3[0-1])\.(0[8]))|((0[1-9]|[1-2][0-9]|3[0])\.(0[9]))|((0[1-9]|[1-2][0-9]|3[0-1])\.(1[0]))|((0[1-9]|[1-2][0-9]|3[0])\.(1[1]))|((0[1-9]|[1-2][0-9]|3[0-1])\.(1[2])))\.[0-9]{2,4})|(2[9])\.(0[2])\.([0-9][0-9](([13579][26])|([02468][048])))";
string input = @"29.02.201";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}