import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((((0[1-9]|[1-2][0-9]|3[0-1])\\.(0[1]))|((0[1-9]|[1-2][0-8])\\.(0[2]))|((0[1-9]|[1-2][0-9]|3[0-1])\\.(0[3]))|((0[1-9]|[1-2][0-9]|3[0])\\.(0[4]))|((0[1-9]|[1-2][0-9]|3[0-1])\\.(0[5]))|((0[1-9]|[1-2][0-9]|3[0])\\.(0[6]))|((0[1-9]|[1-2][0-9]|3[0-1])\\.(0[7]))|((0[1-9]|[1-2][0-9]|3[0-1])\\.(0[8]))|((0[1-9]|[1-2][0-9]|3[0])\\.(0[9]))|((0[1-9]|[1-2][0-9]|3[0-1])\\.(1[0]))|((0[1-9]|[1-2][0-9]|3[0])\\.(1[1]))|((0[1-9]|[1-2][0-9]|3[0-1])\\.(1[2])))\\.[0-9]{2,4})|(2[9])\\.(0[2])\\.([0-9][0-9](([13579][26])|([02468][048])))";
final String string = "29.02.201";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}