package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((((0[1-9]|[1-2][0-9]|3[0-1])\.(0[1]))|((0[1-9]|[1-2][0-8])\.(0[2]))|((0[1-9]|[1-2][0-9]|3[0-1])\.(0[3]))|((0[1-9]|[1-2][0-9]|3[0])\.(0[4]))|((0[1-9]|[1-2][0-9]|3[0-1])\.(0[5]))|((0[1-9]|[1-2][0-9]|3[0])\.(0[6]))|((0[1-9]|[1-2][0-9]|3[0-1])\.(0[7]))|((0[1-9]|[1-2][0-9]|3[0-1])\.(0[8]))|((0[1-9]|[1-2][0-9]|3[0])\.(0[9]))|((0[1-9]|[1-2][0-9]|3[0-1])\.(1[0]))|((0[1-9]|[1-2][0-9]|3[0])\.(1[1]))|((0[1-9]|[1-2][0-9]|3[0-1])\.(1[2])))\.[0-9]{2,4})|(2[9])\.(0[2])\.([0-9][0-9](([13579][26])|([02468][048])))`)
var str = `29.02.201`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}