const regex = /((((0[1-9]|[1-2][0-9]|3[0-1])\.(0[1]))|((0[1-9]|[1-2][0-8])\.(0[2]))|((0[1-9]|[1-2][0-9]|3[0-1])\.(0[3]))|((0[1-9]|[1-2][0-9]|3[0])\.(0[4]))|((0[1-9]|[1-2][0-9]|3[0-1])\.(0[5]))|((0[1-9]|[1-2][0-9]|3[0])\.(0[6]))|((0[1-9]|[1-2][0-9]|3[0-1])\.(0[7]))|((0[1-9]|[1-2][0-9]|3[0-1])\.(0[8]))|((0[1-9]|[1-2][0-9]|3[0])\.(0[9]))|((0[1-9]|[1-2][0-9]|3[0-1])\.(1[0]))|((0[1-9]|[1-2][0-9]|3[0])\.(1[1]))|((0[1-9]|[1-2][0-9]|3[0-1])\.(1[2])))\.[0-9]{2,4})|(2[9])\.(0[2])\.([0-9][0-9](([13579][26])|([02468][048])))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((((0[1-9]|[1-2][0-9]|3[0-1])\\.(0[1]))|((0[1-9]|[1-2][0-8])\\.(0[2]))|((0[1-9]|[1-2][0-9]|3[0-1])\\.(0[3]))|((0[1-9]|[1-2][0-9]|3[0])\\.(0[4]))|((0[1-9]|[1-2][0-9]|3[0-1])\\.(0[5]))|((0[1-9]|[1-2][0-9]|3[0])\\.(0[6]))|((0[1-9]|[1-2][0-9]|3[0-1])\\.(0[7]))|((0[1-9]|[1-2][0-9]|3[0-1])\\.(0[8]))|((0[1-9]|[1-2][0-9]|3[0])\\.(0[9]))|((0[1-9]|[1-2][0-9]|3[0-1])\\.(1[0]))|((0[1-9]|[1-2][0-9]|3[0])\\.(1[1]))|((0[1-9]|[1-2][0-9]|3[0-1])\\.(1[2])))\\.[0-9]{2,4})|(2[9])\\.(0[2])\\.([0-9][0-9](([13579][26])|([02468][048])))', 'gm')
const str = `29.02.201`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}