#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(liestoldbyfemales)[es]{0,1}[s]{0,1}[^A-Za-z]{1}|[^A-Za-z]{1,}(liestoldbyfemales)[es]{0,1}[s]{0,1}[^A-Za-z]{1,}|[^A-Za-z]{1}(liestoldbyfemales)[es|s]{0,2}$"
Local $sString = "LiesToldByFemales RT @LoveQuotes: # \"I\'m done with him.\"" & @CRLF & _
"RT @LoveQuotes: #LiesToldByFemales \"I\'m done with him.\"" & @CRLF & _
"RT @LoveQuotes: # \"I\'m done with him.\" LiesToldByFemales" & @CRLF & _
"RT @LoveQuotes: # \"I\'m done with him.\"" & @CRLF & _
"" & @CRLF & _
" # inizo" & @CRLF & _
" r"^" + keyword + "[es]{0,1}[s]{0,1}[^A-Za-z |]{1}"," & @CRLF & _
" #r"|"" & @CRLF & _
" # in mezzo al testo" & @CRLF & _
" #r"[^A-Za-z]{1,}"+ keyword + "[es]{0,1}[s]{0,1}[^A-Za-z]{1,}|"" & @CRLF & _
" #r"|"" & @CRLF & _
" # alla fine" & @CRLF & _
" #r"[^A-Za-z]{1}" + keyword + "[es|s]{0,2}$","
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")