using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(liestoldbyfemales)[es]{0,1}[s]{0,1}[^A-Za-z]{1}|[^A-Za-z]{1,}(liestoldbyfemales)[es]{0,1}[s]{0,1}[^A-Za-z]{1,}|[^A-Za-z]{1}(liestoldbyfemales)[es|s]{0,2}$";
string input = @"LiesToldByFemales RT @LoveQuotes: # \""I\'m done with him.\""
RT @LoveQuotes: #LiesToldByFemales \""I\'m done with him.\""
RT @LoveQuotes: # \""I\'m done with him.\"" LiesToldByFemales
RT @LoveQuotes: # \""I\'m done with him.\""
# inizo
r""^"" + keyword + ""[es]{0,1}[s]{0,1}[^A-Za-z |]{1}"",
#r""|""
# in mezzo al testo
#r""[^A-Za-z]{1,}""+ keyword + ""[es]{0,1}[s]{0,1}[^A-Za-z]{1,}|""
#r""|""
# alla fine
#r""[^A-Za-z]{1}"" + keyword + ""[es|s]{0,2}$"",";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}