# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(liestoldbyfemales)[es]{0,1}[s]{0,1}[^A-Za-z]{1}|[^A-Za-z]{1,}(liestoldbyfemales)[es]{0,1}[s]{0,1}[^A-Za-z]{1,}|[^A-Za-z]{1}(liestoldbyfemales)[es|s]{0,2}$"
test_str = ("LiesToldByFemales RT @LoveQuotes: # \\\"I\\'m done with him.\\\"\n"
"RT @LoveQuotes: #LiesToldByFemales \\\"I\\'m done with him.\\\"\n"
"RT @LoveQuotes: # \\\"I\\'m done with him.\\\" LiesToldByFemales\n"
"RT @LoveQuotes: # \\\"I\\'m done with him.\\\"\n\n"
" # inizo\n"
" r\"^\" + keyword + \"[es]{0,1}[s]{0,1}[^A-Za-z |]{1}\",\n"
" #r\"|\"\n"
" # in mezzo al testo\n"
" #r\"[^A-Za-z]{1,}\"+ keyword + \"[es]{0,1}[s]{0,1}[^A-Za-z]{1,}|\"\n"
" #r\"|\"\n"
" # alla fine\n"
" #r\"[^A-Za-z]{1}\" + keyword + \"[es|s]{0,2}$\",")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.