use strict;
my $str = 'LiesToldByFemales RT @LoveQuotes: # \\"I\\\'m done with him.\\"
RT @LoveQuotes: #LiesToldByFemales \\"I\\\'m done with him.\\"
RT @LoveQuotes: # \\"I\\\'m done with him.\\" LiesToldByFemales
RT @LoveQuotes: # \\"I\\\'m done with him.\\"
# inizo
r"^" + keyword + "[es]{0,1}[s]{0,1}[^A-Za-z |]{1}",
#r"|"
# in mezzo al testo
#r"[^A-Za-z]{1,}"+ keyword + "[es]{0,1}[s]{0,1}[^A-Za-z]{1,}|"
#r"|"
# alla fine
#r"[^A-Za-z]{1}" + keyword + "[es|s]{0,2}$",';
my $regex = qr/^(liestoldbyfemales)[es]{0,1}[s]{0,1}[^A-Za-z]{1}|[^A-Za-z]{1,}(liestoldbyfemales)[es]{0,1}[s]{0,1}[^A-Za-z]{1,}|[^A-Za-z]{1}(liestoldbyfemales)[es|s]{0,2}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}