#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z]+(?:\s[a-zA-Z]+)*$"
Local $sString = "Válid Full Name:" & @CRLF & _
"David Gilmour" & @CRLF & _
"" & @CRLF & _
"Juan Munoz" & @CRLF & _
"" & @CRLF & _
"Claudio Alberto da Silva" & @CRLF & _
"Invalid Full Name:" & @CRLF & _
"David Gilm01ur Jr." & @CRLF & _
"" & @CRLF & _
"Juan Muñoz" & @CRLF & _
"" & @CRLF & _
"Cláudio Alberto da Silva"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")