re = /^[a-zA-Z]+(?:\s[a-zA-Z]+)*$/m
str = 'Válid Full Name:
David Gilmour
Juan Munoz
Claudio Alberto da Silva
Invalid Full Name:
David Gilm01ur Jr.
Juan Muñoz
Cláudio Alberto da Silva'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end