package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z]+(?:\s[a-zA-Z]+)*$`)
var str = `Válid Full Name:
David Gilmour
Juan Munoz
Claudio Alberto da Silva
Invalid Full Name:
David Gilm01ur Jr.
Juan Muñoz
Cláudio Alberto da Silva`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}