#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"[^"\r\n]*"|"[^"\r\n]*$|(\w+)"
Local $sString = "T1 T3 T5 T8 " " & @CRLF & _
"T1 T3 T5 T8 "T4 " & @CRLF & _
"T1 T3 T5 T8 "T9" " & @CRLF & _
"O2 T3 O5 "T7 T9" O8" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")