package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"[^"\r\n]*"|"[^"\r\n]*$|(\w+)`)
var str = `T1 T3 T5 T8 "
T1 T3 T5 T8 "T4
T1 T3 T5 T8 "T9"
O2 T3 O5 "T7 T9" O8
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}