$re = '/"[^"\r\n]*"|"[^"\r\n]*$|(\w+)/m';
$str = 'T1 T3 T5 T8 "
T1 T3 T5 T8 "T4
T1 T3 T5 T8 "T9"
O2 T3 O5 "T7 T9" O8
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);