using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""[^""\r\n]*""|""[^""\r\n]*$|(\w+)";
string input = @"T1 T3 T5 T8 ""
T1 T3 T5 T8 ""T4
T1 T3 T5 T8 ""T9""
O2 T3 O5 ""T7 T9"" O8
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}