using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\A[a-zA-Z0-9\s\p{Han}]+\z";
string input = @"总理话音一落 部门即抓落实 End";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}